mop-utils results collected by cl-test-grid

Results on the last two Quicklisp distributions

 quicklisp 2017-04-03quicklisp 2017-02-27
abcl-1.2.1-fasl42-linux-x86
(LOAD mop-utils FAIL) COMMON-LISP:READER-ERROR : The package "SB-MOP" can't be found.
(LOAD mop-utils FAIL) COMMON-LISP:READER-ERROR : The package "SB-MOP" can't be found.
abcl-1.3.0-fasl42-linux-x86
(LOAD mop-utils FAIL) COMMON-LISP:READER-ERROR : The package "SB-MOP" can't be found.
(LOAD mop-utils FAIL) COMMON-LISP:READER-ERROR : The package "SB-MOP" can't be found.
abcl-1.3.1-fasl42-linux-x86
(LOAD mop-utils FAIL) COMMON-LISP:READER-ERROR : The package "SB-MOP" can't be found.
(LOAD mop-utils FAIL) COMMON-LISP:READER-ERROR : The package "SB-MOP" can't be found.
abcl-1.3.2-fasl42-linux-x86
(LOAD mop-utils FAIL) COMMON-LISP:READER-ERROR : The package "SB-MOP" can't be found.
(LOAD mop-utils FAIL) COMMON-LISP:READER-ERROR : The package "SB-MOP" can't be found.
abcl-1.3.3-fasl42-macosx-x64
(LOAD mop-utils FAIL) COMMON-LISP:READER-ERROR : The package "SB-MOP" can't be found.
abcl-1.4.0-fasl42-linux-x86
(LOAD mop-utils FAIL) COMMON-LISP:READER-ERROR : The package "SB-MOP" can't be found.
(LOAD mop-utils FAIL) COMMON-LISP:READER-ERROR : The package "SB-MOP" can't be found.
acl-10.0-linux-x86
(LOAD mop-utils FAIL) COMMON-LISP:PACKAGE-ERROR : Using package `COMMON-LISP' results in name conflicts for these symbols: CLOSER-MOP:STANDARD-CLASS CLOSER-MOP:DEFMETHOD CLOSER-MOP:DEFGENERIC CLOSER-MOP:STANDARD-GENERIC-FUNCTION CLOSER-MOP:STANDARD-CLASS CLOSER-MOP:DEFMETHOD CLOSER-MOP:DEFGENERIC CLOSER-MOP:STANDARD-GENERIC-FUNCTION
(LOAD mop-utils FAIL) COMMON-LISP:PACKAGE-ERROR : Using package `COMMON-LISP' results in name conflicts for these symbols: CLOSER-MOP:STANDARD-CLASS CLOSER-MOP:DEFMETHOD CLOSER-MOP:DEFGENERIC CLOSER-MOP:STANDARD-GENERIC-FUNCTION CLOSER-MOP:STANDARD-CLASS CLOSER-MOP:DEFMETHOD CLOSER-MOP:DEFGENERIC CLOSER-MOP:STANDARD-GENERIC-FUNCTION
acl-10.0m-linux-x86
(LOAD mop-utils FAIL) common-lisp:package-error : Using package `common-lisp' results in name conflicts for these symbols: closer-mop:standard-class closer-mop:defmethod closer-mop:defgeneric closer-mop:standard-generic-function closer-mop:standard-class closer-mop:defmethod closer-mop:defgeneric closer-mop:standard-generic-function
(LOAD mop-utils FAIL) common-lisp:package-error : Using package `common-lisp' results in name conflicts for these symbols: closer-mop:standard-class closer-mop:defmethod closer-mop:defgeneric closer-mop:standard-generic-function closer-mop:standard-class closer-mop:defmethod closer-mop:defgeneric closer-mop:standard-generic-function
acl-10.0ms-linux-x86
(LOAD mop-utils FAIL) common-lisp:package-error : Using package `common-lisp' results in name conflicts for these symbols: closer-mop:standard-class closer-mop:defmethod closer-mop:defgeneric closer-mop:standard-generic-function closer-mop:standard-class closer-mop:defmethod closer-mop:defgeneric closer-mop:standard-generic-function
(LOAD mop-utils FAIL) common-lisp:package-error : Using package `common-lisp' results in name conflicts for these symbols: closer-mop:standard-class closer-mop:defmethod closer-mop:defgeneric closer-mop:standard-generic-function closer-mop:standard-class closer-mop:defmethod closer-mop:defgeneric closer-mop:standard-generic-function
acl-10.0s-linux-x86
(LOAD mop-utils FAIL) COMMON-LISP:PACKAGE-ERROR : Using package `COMMON-LISP' results in name conflicts for these symbols: CLOSER-MOP:STANDARD-CLASS CLOSER-MOP:DEFMETHOD CLOSER-MOP:DEFGENERIC CLOSER-MOP:STANDARD-GENERIC-FUNCTION CLOSER-MOP:STANDARD-CLASS CLOSER-MOP:DEFMETHOD CLOSER-MOP:DEFGENERIC CLOSER-MOP:STANDARD-GENERIC-FUNCTION
(LOAD mop-utils FAIL) COMMON-LISP:PACKAGE-ERROR : Using package `COMMON-LISP' results in name conflicts for these symbols: CLOSER-MOP:STANDARD-CLASS CLOSER-MOP:DEFMETHOD CLOSER-MOP:DEFGENERIC CLOSER-MOP:STANDARD-GENERIC-FUNCTION CLOSER-MOP:STANDARD-CLASS CLOSER-MOP:DEFMETHOD CLOSER-MOP:DEFGENERIC CLOSER-MOP:STANDARD-GENERIC-FUNCTION
ccl-1.10-r16196-f96-linux-x86
(LOAD mop-utils FAIL) CCL::USE-PACKAGE-CONFLICT-ERROR : Using #<Package "COMMON-LISP"> in #<Package "MOP-UTILS"> would cause name conflicts with symbols inherited by that package: CLOSER-MOP:STANDARD-METHOD STANDARD-METHOD CLOSER-MOP:STANDARD-GENERIC-FUNCTION STANDARD-GENERIC-FUNCTION CLOSER-MOP:DEFMETHOD DEFMETHOD CLOSER-MOP:DEFGENERIC DEFGENERIC CLOSER-MOP:STANDARD-CLASS STANDARD-CLASS
(LOAD mop-utils FAIL) CCL::USE-PACKAGE-CONFLICT-ERROR : Using #<Package "COMMON-LISP"> in #<Package "MOP-UTILS"> would cause name conflicts with symbols inherited by that package: CLOSER-MOP:STANDARD-METHOD STANDARD-METHOD CLOSER-MOP:STANDARD-GENERIC-FUNCTION STANDARD-GENERIC-FUNCTION CLOSER-MOP:DEFMETHOD DEFMETHOD CLOSER-MOP:DEFGENERIC DEFGENERIC CLOSER-MOP:STANDARD-CLASS STANDARD-CLASS
ccl-1.11-r16635-f96-linux-x86
(LOAD mop-utils FAIL) CCL::USE-PACKAGE-CONFLICT-ERROR : Using #<Package "COMMON-LISP"> in #<Package "MOP-UTILS"> would cause name conflicts with symbols inherited by that package: CLOSER-MOP:STANDARD-METHOD STANDARD-METHOD CLOSER-MOP:STANDARD-GENERIC-FUNCTION STANDARD-GENERIC-FUNCTION CLOSER-MOP:DEFMETHOD DEFMETHOD CLOSER-MOP:DEFGENERIC DEFGENERIC CLOSER-MOP:STANDARD-CLASS STANDARD-CLASS
(LOAD mop-utils FAIL) CCL::USE-PACKAGE-CONFLICT-ERROR : Using #<Package "COMMON-LISP"> in #<Package "MOP-UTILS"> would cause name conflicts with symbols inherited by that package: CLOSER-MOP:STANDARD-METHOD STANDARD-METHOD CLOSER-MOP:STANDARD-GENERIC-FUNCTION STANDARD-GENERIC-FUNCTION CLOSER-MOP:DEFMETHOD DEFMETHOD CLOSER-MOP:DEFGENERIC DEFGENERIC CLOSER-MOP:STANDARD-CLASS STANDARD-CLASS
ccl-1.11-r16635-f96-macosx-x86
(LOAD mop-utils FAIL) CCL::USE-PACKAGE-CONFLICT-ERROR : Using #<Package "COMMON-LISP"> in #<Package "MOP-UTILS"> would cause name conflicts with symbols inherited by that package: CLOSER-MOP:STANDARD-METHOD STANDARD-METHOD CLOSER-MOP:STANDARD-GENERIC-FUNCTION STANDARD-GENERIC-FUNCTION CLOSER-MOP:DEFMETHOD DEFMETHOD CLOSER-MOP:DEFGENERIC DEFGENERIC CLOSER-MOP:STANDARD-CLASS STANDARD-CLASS
ccl-1.8-r15286m-f95-linux-x86
(LOAD mop-utils FAIL) ASDF:LOAD-SYSTEM-DEFINITION-ERROR : Error while trying to load definition for system closer-mop from pathname /home/testgrid/cl-test-grid/work-dir/agent/quicklisp/dists/quicklisp/software/closer-mop-20170403-git/closer-mop.asd: :IF-FEATURE is an invalid initarg to INITIALIZE-INSTANCE for #<STANDARD-CLASS CL-SOURCE-FILE>. Valid initargs: (:NAME :VERSION :DESCRIPTION :LONG-DESCRIPTION :IN-ORDER-TO :DO-FIRST :PARENT :PATHNAME :AROUND-COMPILE :ENCODING :PROPERTIES :TYPE).
(LOAD mop-utils FAIL) ASDF:LOAD-SYSTEM-DEFINITION-ERROR : Error while trying to load definition for system closer-mop from pathname /home/testgrid/cl-test-grid/work-dir/agent/quicklisp/dists/quicklisp/software/closer-mop-20170227-git/closer-mop.asd: :IF-FEATURE is an invalid initarg to INITIALIZE-INSTANCE for #<STANDARD-CLASS CL-SOURCE-FILE>. Valid initargs: (:NAME :VERSION :DESCRIPTION :LONG-DESCRIPTION :IN-ORDER-TO :DO-FIRST :PARENT :PATHNAME :AROUND-COMPILE :ENCODING :PROPERTIES :TYPE).
ccl-1.9-r15756-f96-linux-x86
(LOAD mop-utils FAIL) CCL::USE-PACKAGE-CONFLICT-ERROR : Using #<Package "COMMON-LISP"> in #<Package "MOP-UTILS"> would cause name conflicts with symbols inherited by that package: CLOSER-MOP:STANDARD-METHOD STANDARD-METHOD CLOSER-MOP:STANDARD-GENERIC-FUNCTION STANDARD-GENERIC-FUNCTION CLOSER-MOP:DEFMETHOD DEFMETHOD CLOSER-MOP:DEFGENERIC DEFGENERIC CLOSER-MOP:STANDARD-CLASS STANDARD-CLASS
(LOAD mop-utils FAIL) CCL::USE-PACKAGE-CONFLICT-ERROR : Using #<Package "COMMON-LISP"> in #<Package "MOP-UTILS"> would cause name conflicts with symbols inherited by that package: CLOSER-MOP:STANDARD-METHOD STANDARD-METHOD CLOSER-MOP:STANDARD-GENERIC-FUNCTION STANDARD-GENERIC-FUNCTION CLOSER-MOP:DEFMETHOD DEFMETHOD CLOSER-MOP:DEFGENERIC DEFGENERIC CLOSER-MOP:STANDARD-CLASS STANDARD-CLASS
clisp-2.49-unix-x86
(LOAD mop-utils FAIL) ASDF:LOAD-SYSTEM-DEFINITION-ERROR : Error while trying to load definition for system closer-mop from pathname /home/testgrid/cl-test-grid/work-dir/agent/quicklisp/dists/quicklisp/software/closer-mop-20170403-git/closer-mop.asd: MAKE-INSTANCE: illegal keyword/value pair :IF-FEATURE, :ABCL in argument list. The allowed keywords are (:NAME :VERSION :DESCRIPTION :LONG-DESCRIPTION :IN-ORDER-TO :DO-FIRST :PARENT :PATHNAME :AROUND-COMPILE :ENCODING :PROPERTIES :TYPE)
(LOAD mop-utils FAIL) ASDF:LOAD-SYSTEM-DEFINITION-ERROR : Error while trying to load definition for system closer-mop from pathname /home/testgrid/cl-test-grid/work-dir/agent/quicklisp/dists/quicklisp/software/closer-mop-20170227-git/closer-mop.asd: MAKE-INSTANCE: illegal keyword/value pair :IF-FEATURE, :ABCL in argument list. The allowed keywords are (:NAME :VERSION :DESCRIPTION :LONG-DESCRIPTION :IN-ORDER-TO :DO-FIRST :PARENT :PATHNAME :AROUND-COMPILE :ENCODING :PROPERTIES :TYPE)
cmu-snapshot-2013-04__20d_unicode_-linux-x86
(LOAD mop-utils FAIL) COMMON-LISP:SIMPLE-ERROR : Error in function USE-PACKAGE: Use'ing package COMMON-LISP results in name conflicts for these symbols: (CLOSER-MOP:TYPEP CLOSER-MOP:SUBTYPEP CLOSER-MOP:TYPEP CLOSER-MOP:SUBTYPEP)
(LOAD mop-utils FAIL) COMMON-LISP:SIMPLE-ERROR : Error in function USE-PACKAGE: Use'ing package COMMON-LISP results in name conflicts for these symbols: (CLOSER-MOP:TYPEP CLOSER-MOP:SUBTYPEP CLOSER-MOP:TYPEP CLOSER-MOP:SUBTYPEP)
cmu-snapshot-2014-01__20e_unicode_-linux-x86
(LOAD mop-utils FAIL) COMMON-LISP:SIMPLE-ERROR : Error in function USE-PACKAGE: Use'ing package COMMON-LISP results in name conflicts for these symbols: (CLOSER-MOP:TYPEP CLOSER-MOP:SUBTYPEP CLOSER-MOP:TYPEP CLOSER-MOP:SUBTYPEP)
(LOAD mop-utils FAIL) COMMON-LISP:SIMPLE-ERROR : Error in function USE-PACKAGE: Use'ing package COMMON-LISP results in name conflicts for these symbols: (CLOSER-MOP:TYPEP CLOSER-MOP:SUBTYPEP CLOSER-MOP:TYPEP CLOSER-MOP:SUBTYPEP)
cmu-snapshot-2014-05-dirty__20e_unicode_-linux-x86
(LOAD mop-utils FAIL) COMMON-LISP:SIMPLE-ERROR : Error in function USE-PACKAGE: Use'ing package COMMON-LISP results in name conflicts for these symbols: (CLOSER-MOP:TYPEP CLOSER-MOP:SUBTYPEP CLOSER-MOP:TYPEP CLOSER-MOP:SUBTYPEP)
(LOAD mop-utils FAIL) COMMON-LISP:SIMPLE-ERROR : Error in function USE-PACKAGE: Use'ing package COMMON-LISP results in name conflicts for these symbols: (CLOSER-MOP:TYPEP CLOSER-MOP:SUBTYPEP CLOSER-MOP:TYPEP CLOSER-MOP:SUBTYPEP)
cmu-snapshot-2014-12___20f_unicode_-linux-x86
(LOAD mop-utils FAIL) COMMON-LISP:SIMPLE-ERROR : Error in function USE-PACKAGE: Use'ing package COMMON-LISP results in name conflicts for these symbols: (CLOSER-MOP:TYPEP CLOSER-MOP:SUBTYPEP CLOSER-MOP:TYPEP CLOSER-MOP:SUBTYPEP)
(LOAD mop-utils FAIL) COMMON-LISP:SIMPLE-ERROR : Error in function USE-PACKAGE: Use'ing package COMMON-LISP results in name conflicts for these symbols: (CLOSER-MOP:TYPEP CLOSER-MOP:SUBTYPEP CLOSER-MOP:TYPEP CLOSER-MOP:SUBTYPEP)
cmu-snapshot-2016-12__21b_unicode_-linux-x86
(LOAD mop-utils FAIL) COMMON-LISP:SIMPLE-ERROR : Error in function USE-PACKAGE: Use'ing package COMMON-LISP results in name conflicts for these symbols: (CLOSER-MOP:TYPEP CLOSER-MOP:SUBTYPEP CLOSER-MOP:TYPEP CLOSER-MOP:SUBTYPEP)
(LOAD mop-utils FAIL) COMMON-LISP:SIMPLE-ERROR : Error in function USE-PACKAGE: Use'ing package COMMON-LISP results in name conflicts for these symbols: (CLOSER-MOP:TYPEP CLOSER-MOP:SUBTYPEP CLOSER-MOP:TYPEP CLOSER-MOP:SUBTYPEP)
ecl-13.5.1-unknown-linux-i686-bytecode
(LOAD mop-utils FAIL) SI::SIMPLE-PACKAGE-ERROR : Cannot use #<"CLOSER-MOP" package> from #<"MOP-UTILS" package>, because CLOSER-MOP:STANDARD-GENERIC-FUNCTION and STANDARD-GENERIC-FUNCTION will cause a name conflict.
(LOAD mop-utils FAIL) SI::SIMPLE-PACKAGE-ERROR : Cannot use #<"CLOSER-MOP" package> from #<"MOP-UTILS" package>, because CLOSER-MOP:STANDARD-GENERIC-FUNCTION and STANDARD-GENERIC-FUNCTION will cause a name conflict.
ecl-13.5.1-unknown-linux-i686-lisp-to-c
(LOAD mop-utils FAIL) UIOP/LISP-BUILD:COMPILE-FILE-ERROR : COMPILE-FILE-ERROR while compiling #<cl-source-file "mop-utils" "mop-utils">
(LOAD mop-utils FAIL) UIOP/LISP-BUILD:COMPILE-FILE-ERROR : COMPILE-FILE-ERROR while compiling #<cl-source-file "mop-utils" "mop-utils">
ecl-16.0.0-98fc12d3-linux-i686-bytecode
(LOAD mop-utils FAIL) SI::SIMPLE-PACKAGE-ERROR : Cannot use #<"CLOSER-MOP" package> from #<"MOP-UTILS" package>, because CLOSER-MOP:STANDARD-GENERIC-FUNCTION and STANDARD-GENERIC-FUNCTION will cause a name conflict.
(LOAD mop-utils FAIL) SI::SIMPLE-PACKAGE-ERROR : Cannot use #<"CLOSER-MOP" package> from #<"MOP-UTILS" package>, because CLOSER-MOP:STANDARD-GENERIC-FUNCTION and STANDARD-GENERIC-FUNCTION will cause a name conflict.
ecl-16.0.0-98fc12d3-linux-i686-lisp-to-c
(LOAD mop-utils FAIL) UIOP/LISP-BUILD:COMPILE-FILE-ERROR : COMPILE-FILE-ERROR while compiling #<cl-source-file "mop-utils" "mop-utils">
(LOAD mop-utils FAIL) UIOP/LISP-BUILD:COMPILE-FILE-ERROR : COMPILE-FILE-ERROR while compiling #<cl-source-file "mop-utils" "mop-utils">
ecl-16.0.0-b2661fd1-macosx-x64-bytecode
(LOAD mop-utils FAIL) SI::SIMPLE-PACKAGE-ERROR : Cannot use #<"CLOSER-MOP" package> from #<"MOP-UTILS" package>, because CLOSER-MOP:DEFGENERIC and DEFGENERIC will cause a name conflict.
ecl-16.0.0-b2661fd1-macosx-x64-lisp-to-c
(LOAD mop-utils FAIL) UIOP/LISP-BUILD:COMPILE-FILE-ERROR : COMPILE-FILE-ERROR while compiling #<cl-source-file "mop-utils" "mop-utils">
ecl-16.1.2-unknown-linux-x86-bytecode
(LOAD mop-utils FAIL) SI::SIMPLE-PACKAGE-ERROR : Cannot use #<"CLOSER-MOP" package> from #<"MOP-UTILS" package>, because CLOSER-MOP:STANDARD-GENERIC-FUNCTION and STANDARD-GENERIC-FUNCTION will cause a name conflict.
(LOAD mop-utils FAIL) SI::SIMPLE-PACKAGE-ERROR : Cannot use #<"CLOSER-MOP" package> from #<"MOP-UTILS" package>, because CLOSER-MOP:STANDARD-GENERIC-FUNCTION and STANDARD-GENERIC-FUNCTION will cause a name conflict.
ecl-16.1.2-unknown-linux-x86-lisp-to-c
(LOAD mop-utils FAIL) UIOP/LISP-BUILD:COMPILE-FILE-ERROR : COMPILE-FILE-ERROR while compiling #<cl-source-file "mop-utils" "mop-utils">
(LOAD mop-utils FAIL) UIOP/LISP-BUILD:COMPILE-FILE-ERROR : COMPILE-FILE-ERROR while compiling #<cl-source-file "mop-utils" "mop-utils">
sbcl-1.0.58-linux-x86
sbcl-1.1.11-linux-x86
sbcl-1.1.16-linux-x86
sbcl-1.2.6-linux-x86
sbcl-1.3.12-linux-x86
sbcl-1.3.2.92-4077405-macosx-x64

Breakdown by testcases: for every failed testcase the lisp implmentations it fails on

The library does not have a testsuite adapter for CL Test Grid.

To reports overview

Generated at: 2017-04-12 07:51:14 GMT.