/[climacs]/climacs/INSTALL
ViewVC logotype

Contents of /climacs/INSTALL

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.10 - (show annotations)
Sun Dec 10 19:37:12 2006 UTC (7 years, 4 months ago) by thenriksen
Branch: MAIN
CVS Tags: HEAD
Changes since 1.9: +0 -1 lines
It's no longer necessary to check out ESA.
1 *Note*: Climacs depends on McCLIM, a graphic toolkit for Common Lisp
2 (http://www.cliki.net/McCLIM) and CLX, a low level, Xlib-like library
3 on top of which McCLIM is built (http://www.cliki.net/CLX). Make sure
4 these are properly installed on your system before attempting to install
5 Climacs.
6
7 Install instructions for Climacs. We assume that if you have gotten
8 this far, it means that you have either extracted a tar file with
9 everything in it, or checked out the files from some CVS repository.
10
11 0. You need to check out the flexichain project from
12 common-lisp.net. If you are not a member of those projects, here is
13 how you do it:
14
15 cvs -z3 -d :pserver:anonymous:anonymous@common-lisp.net:/project/flexichain/cvsroot co flexichain
16
17 Ensure that asdf can find the .asd files for these projects. Recent
18 versions of McCLIM depend on Flexichain, and thus, you might
19 already have it installed.
20
21 1. Start Lisp either from the shell or from Emacs
22
23 2. (load "climacs.asd")
24
25 This command will load the system definition file containing system
26 definitions both for ASDF and for MK:DEFSYSTEM.
27
28 3. (asdf:operate 'asdf:load-op :climacs)
29
30 This command will compile and load the source files in the right
31 order.
32
33 4. (climacs:climacs)
34
35 Start the Climacs editor. Alternatively, try (climacs:climacs
36 :new-process t), to start Climacs in a new thread.
37
38 Finally, please notice that as we develop Climacs, we occasionally
39 find bugs in McCLIM, or ask for functionality of McCLIM that can be
40 useful to us.
41
42 For that reason, Climacs often depends on very fresh CVS versions of
43 McCLIM. If you discover a bug, please try to install a new version of
44 McCLIM before looking too hard for any other reasons.

  ViewVC Help
Powered by ViewVC 1.1.5