/[climacs]/climacs/INSTALL
ViewVC logotype

Diff of /climacs/INSTALL

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

revision 1.7 by abakic, Sun Sep 25 20:06:25 2005 UTC revision 1.8 by crhodes, Sat Mar 25 22:29:12 2006 UTC
# Line 7  Climacs. Line 7  Climacs.
7  Install instructions for Climacs.  We assume that if you have gotten  Install instructions for Climacs.  We assume that if you have gotten
8  this far, it means that you have either extracted a tar file with  this far, it means that you have either extracted a tar file with
9  everything in it, or checked out the files from some CVS repository.  everything in it, or checked out the files from some CVS repository.
 If your directory contains a Flexichain subdirectory, skip directly to  
 paragraph 1 below.  Otherwise start at paragraph 0.  
10    
11  0. You need to check out the Flexichain module from the Gsharp project  0. You need to check out the flexichain and esa projects from
12     on common-lisp.net.  If you are a member of that project, you can     common-lisp.net. If you are not a member of those projects, here is
13     do this:     how you do it:
14    
15      export CVS_RSH=ssh      cvs -z3 -d :pserver:anonymous:anonymous@common-lisp.net:/project/flexichain/cvsroot co flexichain
16      cvs -z3 -d :ext:<username>@common-lisp.net:/project/gsharp/cvsroot co Flexichain      cvs -z3 -d :pserver:anonymous:anonymous@common-lisp.net:/project/climacs/cvsroot co esa
17    
18     If you are not a member, here is how you do it:     Ensure that asdf can find the .asd files for these projects.
   
     cvs -d :pserver:anonymous@common-lisp.net:/project/gsharp/cvsroot login  
     <enter anonymous as password>  
     cvs -z3 -d :pserver:anonymous@common-lisp.net:/project/gsharp/cvsroot co Flexichain  
19    
20  1. Start Lisp either from the shell or from Emacs  1. Start Lisp either from the shell or from Emacs
21    
# Line 46  useful to us. Line 40  useful to us.
40  For that reason, Climacs often depends on very fresh CVS versions of  For that reason, Climacs often depends on very fresh CVS versions of
41  McCLIM.  If you discover a bug, please try to install a new version of  McCLIM.  If you discover a bug, please try to install a new version of
42  McCLIM before looking too hard for any other reasons.  McCLIM before looking too hard for any other reasons.
   
   

Legend:
Removed from v.1.7  
changed lines
  Added in v.1.8

  ViewVC Help
Powered by ViewVC 1.1.5